phpunit@CakePHPでのFatal error

CakePHP3.4でphpunitが動かない。


composer require --dev phpunit/phpunit

これでテストを行うと以下がでる。


PHP Fatal error:  Class 'PHPUnit_Framework_TestCase' (略)

調べてみるとCakePHP3.3~+PHPUnit6以上で起こるらしい。

対策は、Cakeのversionを上げるか、PHPUnitを5にすればいいので後者をとった。


composer remove phpunit/phpunit
composer require --dev phpunit/phpunit=5.*

コメントする




one × 1 =